[seL4] Strange Behevior with cma34cr.

Dan DaCosta chaosape at gmail.com
Thu Feb 8 07:43:41 AEDT 2018


To Whom It May Concern:

My name is Dan DaCosta and I am working with Rockwell on a smaccms
transition project referred to as HTA.
The manifest associated with this project can be found here:
https://github.com/smaccm/hta
This manifest is mostly concerned with targeting the cma34cr board.

When building images using a Fedora 26 based OS that relies on gcc 7 the
following fault occurs:

FAULT HANDLER: data fault from vm.ethdriver.control (ID 0x202) on address
> 0x1076878, pc = 0x4070d5, fsr = 0x6
> FAULT HANDLER:       rip = 0x4070d5
> FAULT HANDLER:       rsp = 0x1076880
> FAULT HANDLER:       rax = 0
> FAULT HANDLER:       rbx = 0xe68000
> FAULT HANDLER:       rcx = 0x8
> FAULT HANDLER:       rdx = 0x5
> FAULT HANDLER:       rsi = 0xe61000
> FAULT HANDLER:       rdi = 0xc
> FAULT HANDLER:        r8 = 0
> FAULT HANDLER:        r9 = 0
> FAULT HANDLER:       r10 = 0x16997e000
> FAULT HANDLER:       r11 = 0x246
> FAULT HANDLER:       r12 = 0
> FAULT HANDLER:       r13 = 0x404a70
> FAULT HANDLER:       r14 = 0
> FAULT HANDLER:       r15 = 0
> FAULT HANDLER:    rflags = 0x10246
> FAULT HANDLER:  tls_base = 0
> FAULT HANDLER:   memory map:
> FAULT HANDLER:     +-- 0x0000000001081fff --
> FAULT HANDLER:     |   guard page
> FAULT HANDLER:     +-- 0x0000000001081000 --
> FAULT HANDLER:     |   stack
> FAULT HANDLER:     +-- 0x000000000107d000 --
> FAULT HANDLER:     |   guard page
> FAULT HANDLER:     +-- 0x000000000107c000 --
> FAULT HANDLER:     |   <undescribed>
> FAULT HANDLER:     +-- 0x0000000001069fff --
> FAULT HANDLER:     |   guard page
> FAULT HANDLER:     +-- 0x0000000001069000 --
> FAULT HANDLER:     |   IPC buffer
> FAULT HANDLER:     +-- 0x0000000001068000 --
> FAULT HANDLER:     |   guard page
> FAULT HANDLER:     +-- 0x0000000001067000 --
> FAULT HANDLER:     |   <undescribed>
> FAULT HANDLER:     +-- 0x000000000105dfff --
> FAULT HANDLER:     |   code and data
> FAULT HANDLER:     +-- 0x0000000000400000 --
>

The config I am primarily interested in is named "cma34cr_centos_defconfig"
but I seem to have similar problems for all the cma34cr defconfigs.

I was successful at building working images when I switched to building on
Ubuntu 16.04 LTS.
This distribution version uses gcc 5.4.

Thanks!
Dan DaCosta
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://sel4.systems/pipermail/devel/attachments/20180207/3479d4b6/attachment.html>


More information about the Devel mailing list